Genie Discord forum

Author AvatarCraz3Coyote
8/21/2023, 11:43:53 PM

Hello, I search high and low but couldn't figure out the problem. so here I am! I'm new to Julia. I am using Windows11 and Julia 1.9

The problem I am having is when I click on the "Start Server" button in the extension I get this error:

Rene@DESKTOP-Rene MINGW64 ~/.vscode/extensions/geniebuilder.geniebuilder-0.4.11/scripts $ julia --startup-file=no --depwarn=no c:\Users\Rene.vscode\extensions\geniebuilder.geniebuilder-0.4.11\scripts/rungb.jl ERROR: SystemError: opening file "C:\Users\Rene\.vscode\extensions\geniebuilder.geniebuilder-0.4.11\scripts\UsersRene.vscodeextensionsgeniebuilder.geniebuilder-0.4.11scripts\rungb.jl": No such file or directory

If I run this code code manually I have no problems in starting the server:

$ julia --startup-file=no --depwarn=no c:\Users\Rene.vscode\extensions\geniebuilder.geniebuilder-0.4.11\scripts/rungb.jl

I noticed this... like its adding the directory twice? How do I fix this or better yet, where is the Start Server code?

ERROR: SystemError: opening file "C:\Users\Rene\.vscode\extensions\geniebuilder.geniebuilder-0.4.11\scripts\UsersRene.vscodeextensionsgeniebuilder.geniebuilder-0.4.11scripts\rungb.jl": No such file or directory

Author AvatarGenerallyClueless
8/22/2023, 1:08:40 PM

welcome to the community @Craz3Coyote

Author AvatarGenerallyClueless
8/22/2023, 1:23:21 PM

Can I ask how you had installed Julia? The recommended method is to use juliaup ... which can be installed from github ( . These are the instructions for installing Genie Builder which include the recommendation to use juliaup (scroll near the bottom).

I use Linux... but I installed julia without using juliaup, and it caused me a lot of headaches trying to make it julia / Genie Builder work with VSCode. VSCode always seemed to use a different PATH for it's terminal that my system PATH... and I had even changed the PATH in VSCode terminal, but it is not persistent. I had also confirmed the environmental variable for the Julia Path in VSCode Settings. It was a mess... until I finally used juliaup.

Here is a link to my original post, in case my experience would help you to get your system configured the right way

Then you just have to learn to drive Genie Builder ๐Ÿ‘ and everything will work out.

Author AvatarCraz3Coyote
8/22/2023, 6:19:05 PM

OK, I figure it out. My default program had changed to Bash for some reason. I just changed it to CMD and it worked. I did change to Juliaup however. Thanks for the help! I did learn a few more things on VSCODE. ๐Ÿ‘