Genie Discord forum

Author AvatarEmpoweringArtsStudios
6/19/2023, 6:45:07 PM

'''ERROR: ArgumentError: Package GenieBuilder not found in current path.

  • Run import Pkg; Pkg.add("GenieBuilder") to install the GenieBuilder package. Stacktrace: 1 macro expansion @ .\loading.jl:1163 inlined2 macro expansion @ .\lock.jl:223 inlined3 require(into::Module, mod::Symbol) @ Base .\loading.jl:1144

when I try to import I get this: (@v1.8) pkg> add GenieBuilder ERROR: The following package names could not be resolved:

  • GenieBuilder (not found in project, manifest or registry) Suggestions: GenieBuiltLifeProto'''
Author AvatarPere
6/20/2023, 10:27:42 AM

The GenieBuilder package should be installed automatically when you start the Genie Builder server., after installing the plugin.

Could you try deleting the folder ~/.julia/geniebuilder, and installing the plugin again?

Author AvatarEmpoweringArtsStudios
6/20/2023, 2:46:27 PM

it doesnt appear to be on my drive, and i'm asked to add it, but I havent' been able to add it through repl or terminal

Author AvatarEmpoweringArtsStudios
6/20/2023, 2:49:22 PM

..ive reinstalled the plug in it start downloading the same error as above using v0.4.7

Author AvatarEmpoweringArtsStudios
6/20/2023, 2:53:44 PM

Stacktrace: 1 pipeline_error @ .\process.jl:565 inlined2 run(::Cmd; wait::Bool) @ Base .\process.jl:480 3 run @ .\process.jl:477 inlined4 |> @ .\operators.jl:911 inlined

Author AvatarPere
6/21/2023, 4:40:06 PM

I just tried to reinstall and it worked ok. Can you provide the full error you see in the terminal?

Author AvatarAkaneKatsu
9/19/2023, 2:13:53 PM

I was facing the same issue as well but after deleting the ~/.julia/geniebuilder it worked just fine! thank you @Pere