Genie Discord forum

Author Avatarsdobber
4/12/2023, 5:13:58 PM

I am trying to import a Genie app with a routes.jl file into Genie Cloud. When trying to start the app from the REPL to see if it can be loaded properly, Genie ends up in a loop, loading the app over and over again. After pressing Ctrl-C, the "Ready" text is printed a number of times before returning to the REPL - see the attached video.

Is there some special startup logic in place that automatically is used on Genie Cloud?

Author Avatarabhimanyuaryan
4/13/2023, 2:43:20 AM

no, I haven't seen this. What version of Genie are you using? Can you zip your project and send it over so I can debug what's happening?

Author AvatarPere
4/13/2023, 9:00:46 AM

Just chipping in with some info:@sdobber I tried with your meetup demo and It loads without issues

Author Avatarsdobber
4/15/2023, 7:10:34 AM

Sorry for the late reply, and thank you for following up! Interesting.... The Meetup Demo is a lot simpler than what I tried to run - it might be that I introduced some configuration hacks which mess things up. I'll try to compare the two projects later when I have time.

Author Avatarsdobber
4/15/2023, 7:12:22 AM

If you send me your Github usernames, I can try to invite you to my private project which gives the issues

Author Avatarsdobber
4/15/2023, 7:00:08 PM

I think I know what happened now... I added a file app.jl to see if I can use that as an entrypoint for GenieCloud for classical Genie apps, with code that loads and starts the app. The auto-file-inclusion mechanism of Genie loads this file and executes it, thus triggering a reload of the app over and over again. ๐Ÿ˜Š

Author AvatarPere
4/17/2023, 6:13:30 AM

sure @sdobber , they're PGimenez and AbhimanyuAryan