Genie Discord forum

Author Avatargrahamas
3/10/2023, 9:47:40 PM

Based on the code, I assume it's supposed to replace null with "Hello world!" This occurs when I just create a new app in GenieBuilder and do nothing else. Am I missing a step or is my set-up misconfigured?

GenieBuilder v0.2.6

GenieFramework v1.9.0 julia> versioninfo() Julia Version 1.8.5 Commit 17cfb8e65ea (2023-01-08 06:45 UTC) Platform Info: OS: Linux (x86_64-linux-gnu) CPU: 16 × AMD Ryzen 9 5900HS with Radeon Graphics WORD_SIZE: 64 LIBM: libopenlibm LLVM: libLLVM-13.0.1 (ORCJIT, znver3) Threads: 1 on 16 virtual cores Environment: JULIA_EDITOR = code JULIA_NUM_THREADS =

Author Avatargrahamas
3/10/2023, 9:51:41 PM
┌ Info: 2023-03-10 14:41:30 
└ Web Server starting at - press Ctrl/Cmd+C to stop the server. 
[ Info: 2023-03-10 14:41:30 Listening on:, thread id: 1
┌ Error: 2023-03-10 14:41:34 Failed to store session data
└ @ GenieSessionFileSession ~/.julia/packages/GenieSessionFileSession/otnJC/src/GenieSessionFileSession.jl:41
┌ Error: 2023-03-10 14:41:34 ArgumentError("embedded NULs are not allowed in C strings: \"/tmp/jl_Y4chKp/\\x12凭\\a!&c\\xc7Ԧ\\xd7\\x1e\\xd8\\xf8\\x95\\xa1F\\x147\\x9b=ݍ\\xbd~TQ\\n=\\xda.\\xf8˫\\x9er]|\\x9al8\\xb39,\\xc8w \\0\\xf6\\x98\\xec\\xe7\\xdb\\xf1\\x96}\\x0e\\xeb\\x1e\\xcb\\x1c\\xeb\\xed\\xa0w\\xb5.7\\x8b.u\\x0f-K\\x88)\\x9d\\x0f\\0\"")
└ @ GenieSessionFileSession ~/.julia/packages/GenieSessionFileSession/otnJC/src/GenieSessionFileSession.jl:42
┌ Error: 2023-03-10 14:41:34 Resetting session
└ @ GenieSessionFileSession ~/.julia/packages/GenieSessionFileSession/otnJC/src/GenieSessionFileSession.jl:46
[ Info: 2023-03-10 14:41:34 GET /_devtools_/id 200
WARNING: both HttpCommon and Genie export "Headers"; uses of it in module Html must be qualified
WARNING: both Html and Base export "div"; uses of it in module Stipple must be qualified
WARNING: both Router and Base export "download"; uses of it in module Genie must be qualified
WARNING: both Html and Base export "mark"; uses of it in module Stipple must be qualified
WARNING: both Html and Base export "summary"; uses of it in module Stipple must be qualified
WARNING: both Html and Base export "time"; uses of it in module Stipple must be qualified
WARNING: both Html and Base export "view"; uses of it in module Stipple must be qualified
[ Info: 2023-03-10 14:41:41 GET /_devtools_/pages?CHANNEL__=ZNGNAVNUYNXODHAKDDJYZWQMINKTLPJN 200
┌ Error: 2023-03-10 14:41:41 GET /images/icons/GenieCloud_logo.png 404
└ @ Genie.Router ~/.julia/packages/Genie/IZLml/src/Router.jl:204
[ Info: 2023-03-10 14:41:41 GET /_devtools_/pages?CHANNEL__=ZNGNAVNUYNXODHAKDDJYZWQMINKTLPJN 200
Author Avatargrahamas
3/10/2023, 9:53:41 PM

That's followed by a dozen successful GETs mostly of js and css

Author Avatarabhimanyuaryan
3/13/2023, 5:51:54 PM

is this error with the default application? i.e. the boilerplate application that GB produces?

Author Avatargrahamas
3/15/2023, 8:45:24 PM

Yes. All I did was click the plus arrow ("Genie Builder: Create new app"), give it a name, and open the WYSIWYG or whatever you call it

Author Avatargrahamas
3/15/2023, 8:50:24 PM

I just restarted the server and the app and this time the only error in the log was

Author Avatargrahamas
3/15/2023, 8:50:26 PM

┌ Error: 2023-03-15 13:48:07 GET /images/icons/GenieCloud_logo.png 404 └ @ Genie.Router ~/.julia/packages/Genie/2Y9Bp/src/Router.jl:204

Author Avatargrahamas
3/15/2023, 8:51:47 PM

plus the warnings about qualifying exports, but no weird NUL character errors like last time

Author Avatargrahamas
3/15/2023, 8:52:04 PM

and here's the app.jl:

Author Avatargrahamas
3/15/2023, 8:52:12 PM
module App

using GenieFramework

@handlers begin
  @out message = "Hello World!"

  @onchange isready begin
    @show "App is loaded"

@page("/", "app.jl.html")

Author Avatarabhimanyuaryan
3/17/2023, 9:29:53 AM

can you remove ~/.julia/geniebuilder directly and remove gb extension and try again?

Author Avatargrahamas
3/17/2023, 9:32:28 PM

It seems extra broken now? Are there additional reinstall or uninstall steps I need to follow? I deleted ~/.julia/geniebuilder and uninstalled the Genie Builder extension in vscode. Then I restarted vscode. Then I reinstalled the Genie Builder extension. Now:

  1. My old testing app (just the default app) appears in Genie Builder Apps but obviously has no files and there doesn't seem to be a way to remove it.
  2. The Genie Builder Server is "running" but the Stop Server button doesn't do anything.
  3. Adding a new app prompts for an app name, but then does nothing
Author Avatargrahamas
3/17/2023, 9:34:07 PM

Also the Genie Builder console in vscode has a bunch of errors in it, but they're truncated so I can't tell when they came from, nor can I replicate them. Re-starting vscode just adds a new shell prompt to the bottom, suggesting that the server is not, in fact, running. Here are the only non-truncated errors:

Author Avatarabhimanyuaryan
3/18/2023, 7:46:21 PM

Question. Are you using GenieBuilder or GenieBuilder Insider?

  1. old testing app is appearing in GenieBuilder because maybe it's added in db. Can you not right click and purge it?

error stack: I am not sure why db is read only

Author Avatargrahamas
3/18/2023, 11:43:48 PM


Right clicking didn't give any options, but I'll double check

Author Avatarabhimanyuaryan
3/19/2023, 5:42:54 PM

Something sounds off. The is the first time I am seeing this error.

Author Avatarabhimanyuaryan
3/19/2023, 5:45:46 PM

I have not tested GenieBuilder on Linux for a long time. I'll need to fix my Linux dual boot issue to test it out. I'll response later

Author Avatarabhimanyuaryan
3/21/2023, 1:44:41 PM

sorry for delay I'll test GB.jl today on my linux machine. I fixed the boot issue

Author Avatarabhimanyuaryan
3/21/2023, 8:13:46 PM

Just verified works perfectly fine. I think there are some write/read issues with your ~/.julia/geniebuilder directory

Author Avatarabhimanyuaryan
3/21/2023, 8:14:36 PM

Let me change the old code to new one

Author Avatarabhimanyuaryan
3/21/2023, 8:19:27 PM

But that is not the problem. It should work with the old API as well

Author Avatargrahamas
3/22/2023, 5:15:18 AM

That could be it. Is there another user that needs permissions? Right now the owner (my user) has full permissions and everyone else has read/execute

Author Avatargrahamas
3/22/2023, 5:17:50 AM

This isn't true anymore (or I misremembered). Right clicking gives three options: Launch Repl, Package Manager, and Stop App.

Author Avatargrahamas
3/22/2023, 5:18:16 AM

Launch REPL now runs and gives a meaningful error:

Author Avatargrahamas
3/22/2023, 5:19:14 AM

This is because I deleted (and didn't recreate) my geniebuilder folder

Author Avatargrahamas
3/22/2023, 5:19:48 AM

Creating the folder and then re-running Launch REPL, I get this:

Author Avatargrahamas
3/22/2023, 5:20:02 AM

I'll try deleting the folder and reinstalling geniebuilder again

Author Avatargrahamas
3/22/2023, 5:23:13 AM

The reinstall doesn't create the geniebuilder directory

Author Avatargrahamas
3/22/2023, 5:24:13 AM

Is it possible the uninstall isn't working correctly, causing the reinstall to think it doesn't need to recreate .julia/geniebuilder?

Author Avatargrahamas
3/22/2023, 5:45:16 AM

Where does it store the list of GB apps?

Author Avatarabhimanyuaryan
3/22/2023, 1:05:56 PM

the apps are stored in ~/.julia/geniebuilder/apps

Author Avatarabhimanyuaryan
3/22/2023, 1:09:21 PM

so we will verify if there's any existing vscode extension that's blocking geniebuilder

Author Avatargrahamas
3/24/2023, 6:23:56 AM

I more meant: how does it list these apps when I've deleted ~/.julia/geniebuilder?

Author Avatargrahamas
3/24/2023, 6:27:19 PM

The biggest problems (that I got from deleting ~/.julia/geniebuilder) resolved with a reinstall of vscode. (note: I'm on Arch so it's already an open-source build, like VSCodium)

Author Avatargrahamas
3/24/2023, 6:27:27 PM

I'm still getting null

Author Avatargrahamas
3/24/2023, 6:28:16 PM

I installed VSCodium separately, with the same null result

Author Avatargrahamas
3/24/2023, 6:28:27 PM

I'm going to try uninstalling both and installing one of the Microsoft binaries

Author Avatargrahamas
3/24/2023, 6:38:21 PM

Still getting null even with an official vscode binary

Author Avatargrahamas
3/24/2023, 6:47:47 PM

I tried it on a different (Ubuntu) computer, still getting null

Author Avatargrahamas
3/24/2023, 6:47:55 PM

I also tried disabling all other extensions

Author Avatargrahamas
3/24/2023, 6:55:31 PM

Also it won't let me stop the server

Author Avatargrahamas
3/24/2023, 6:56:20 PM

and every time I removed the (stopped) app folder from my workspace, it added it back almost immediately

Author Avatarabhimanyuaryan
3/25/2023, 8:22:07 AM

Actually it should add genie builder directly on server start so that's correct

Author Avatarabhimanyuaryan
3/25/2023, 8:23:17 AM

Can you record a video and send it so I can see exactly what's happening?

Author Avatargrahamas
3/25/2023, 8:24:17 AM

Sure, do you want it from a fresh install or just the null in the header of a new app?

Author Avatarabhimanyuaryan
3/25/2023, 4:10:04 PM

@grahamas damn it works perfectly fine

Author Avatarabhimanyuaryan
3/25/2023, 4:11:01 PM

that {{ message }} thing where you build your UI. You right-click on that GET/ in the left pane and you'll see the option to preview the app. That's where you see data app

Author Avatarabhimanyuaryan
3/25/2023, 4:13:53 PM

follow tutorials to understand how to build data apps with GB/GenieCloud here:

Author Avatargrahamas
3/25/2023, 7:29:55 PM

I didn't understand that from the quickstart at all--- though I see now that the last gif implies it. And the "Designing the UI with the no-code editor" makes it obvious