Genie Discord forum

Author Avatarjernej
2/13/2023, 6:35:51 AM

What are prerequisites for using Genie Builder 0.2 or higher? Obviouslly, installed Genie Framework package. What else? Any dependencies in Julia, Python, vue, node.js, or VS code? Any particular settings in VS Code?

Background: Somehow I cannot access element properties in no-code builder. I am having the issue on multiple arhitectures and multiple OS. It is all the same, if I use Genie Builder insider or regular and v0.1.x or 0.2.x or 0.3.1-0.3.3. I have checked the the tutorials and documentation, with little success.

Looks like systematic error on my side and I would appreciate help.

Author AvatarPere
2/13/2023, 1:46:44 PM

The only prerequisites are Julia, VSCode and the Genie Builder extension. When it starts it'll automatically install all the packages it needs. I just did a new install on a new computer (Mac) with the latest VSCode and GB plugin and it worked out of the box.

I see you mentioned in #genie-builder that were getting this error: error Extension Host GBVSC-StatusMonitor:::General::socket-error:WebSocket was closed before the connection was established.

Are there any other errors? Did you get this in every one of your tests on multiple OSs?

Author Avatarabhimanyuaryan
2/13/2023, 2:24:43 PM

no prerequisites but the only recommendation I can make is use julia 1.9 beta 4. or anything 1.9 it's faster ๐Ÿ™‚

Author Avatarabhimanyuaryan
2/13/2023, 2:26:56 PM

this error is irrelevant


it just says socket connection was closed. What error are you getting besides this. You can share any form of screencast or gif or screenshot??

Author Avatarabhimanyuaryan
2/13/2023, 2:27:44 PM

also try removing

~/.julia/geniebuilder and re-install vscode extension. Let me know if that fixes the issues

Author Avatarjernej
2/22/2023, 11:14:19 AM

I have tried with julia 1.9 beta 4. Wau.. the speed... ๐Ÿ™‚

The problem persists in Julia 1.9b4, although in different form. Since Genie Builder Insider v0.3.3, I get black screen instead of no code editor. This is consistent across Julia v1.8 and Julia v1.9b4 and GB Insider v0.3.3-0.3.8.

I have tried removing GB subfolder in .julia and .vscode folders and reinstalling GB extension (and variations of these) and I always end up with the same problem.

Under Develeper Tools, I see some errors. I am attaching screenshots of what happens when nocodeEditor is clicked.

Author Avatarjernej
2/24/2023, 9:47:46 AM

It turns out the source of the error is access to . For some reason my computer could not connect to the domain and download these libraries: underscore-min.js, vue.min.js and stipplecore.js. After using VPN, the GB was able to download the libraries and now No code editor works.