Genie Discord forum

Author Avatareli
11/14/2022, 5:50:55 PM

I tried to start Genie Builder but got the error: "cannot bind to port; may already be in use or access denied". I am using windows and Julia version 1.8.2.

Author Avatarkungfupanda007
11/15/2022, 3:41:50 AM

@eli always stop/shut down your server using Ctrl+C key. this will close the genie server and free the port. Right now your that port is already occupied. You can restart your PC, this will automatically free your port. or else you can change the port number in configuration and run the server on some other port.

Author Avataressenciary
11/15/2022, 11:21:10 AM

on *nix you can also kill all the Julia processes via terminal, with sudo killall julia

Author Avataressenciary
11/15/2022, 11:21:26 AM

sometimes the apps don't get properly stopped - we'll look into it

Author Avataressenciary
11/15/2022, 11:21:48 AM

on windows you could kill all julia processes with taskkill /F /IM julia.exe /T

Author Avataressenciary
11/15/2022, 11:22:03 AM

then just restart the Genie Builder server (and/or VSCode)

Author Avatareli
11/15/2022, 2:05:03 PM

Thank you both! I tried restarting the PC yesterday and the error occurred again, but restarting again today seems to have fixed it. However, launching the no code editor still results in a blank screen:

Author Avatareli
11/15/2022, 2:27:32 PM

Also, I have only gotten the Genie Builder Server running after changing App Server Port to 8000. When set to the default 10101, it doesn't seem to finish starting. But with 8000, I still get the blank screen.

Author Avatareli
11/17/2022, 12:43:13 AM

@essenciary Any ideas what I'm doing wrong?

Author AvatarPere
11/17/2022, 2:33:48 PM

@eli can you try with the GB insider version on VScode? Also, try resetting the environment by deleting the ~/.julia/geniebuilder folder

Author Avatareli
11/17/2022, 2:56:15 PM

@Pere So I uninstalled GB and installed GB insider, then deleted ~/.julia/geniebulder and left the port at default 10101. Now when I click Start Server it goes through the loading process and Current Status changes from "starting" to "running" for a few moments before changing back to "stopped". It allow me to click "create app" but then gives the error that it appears no server is running. It appears there are julia processes running in the background for the server because when I run the kill all julia processes it kills 2 processes.

Author Avatareli
11/17/2022, 3:30:24 PM

I thought I would try GB Insider in Windows Subsystem for Linux to get around a potential problem with windows. Unfortunately, this didn't work either. The server appeared to start correctly. However, when I tried to launch an app there was an issue with the GenieBuilder environment not being instantiated. After manually instantiating the environment, I ran into the following error:

Author Avataressenciary
11/17/2022, 5:43:09 PM

@eli don't know what to say, should work equally well on windows

Author Avataressenciary
11/17/2022, 5:44:02 PM

what versions of Julia, VSCode and GenieBuilder are you using?

Author Avataressenciary
11/17/2022, 5:57:07 PM

I suggest opening an issue on Github so we can dive in it

Author Avatareli
11/28/2022, 8:42:34 PM

Genie Builder is now working for me!